Zenzanon-PS stiff aperture ring - fixable?

Share your advice about camera repair or ask a question.
Post Reply
scott
Frequent Poster
Frequent Poster
Posts: 570
Joined: Thu Jul 10, 2014 11:06 am
x 2
x 76
Contact:

Zenzanon-PS stiff aperture ring - fixable?

Post by scott » Fri Jun 04, 2021 11:08 am

Hi all -

I'm rediscovering my Bronica SQ-A kit. Part of that is the Zenzanon-PS 110/4 macro. I got it as a portrait lens, and it excels as that, but the aperture ring is pretty stiff. Not impossible to move, but more difficult than I'd like for a user. The blades seem well set and clean.

Anyone been into one of the SQ-series Zenzanon lenses? Is this something doable? The lens is selling for ~$225 currently, so probably not worth the cost of a legit repair, but enough that I don't want to booger it up further with my ineptitude.

Thanks,
Scott

User avatar
melek
Prolific Poster
Prolific Poster
Posts: 1038
Joined: Mon Mar 24, 2014 7:04 pm
x 24
x 47
Contact:

Re: Zenzanon-PS stiff aperture ring - fixable?

Post by melek » Mon Jun 07, 2021 6:30 am

I've been thinking about your question since yesterday. Most modern day aperture rings had a detente ball (for the click stops) with lubrication to allow you to turn the ring.

If the ring is stiff, I would thing there might be three possibilities:

1. The ring has some hardened grease that is preventing it from rotating smoothly.
2. The detente ball might have popped out of place for some reason.
3. Something in the aperture coupling or linkage is either out of place or corroded that is keeping the ring from rotating smoothly.

The fact that the blades seem to be clean and seated correctly lead me to think it's either No. 2 or No 1 (in that order). If the click stops for the aperture setting seem positive, it might be No. 1.

Of course, I always add that anything is possible, and it might not be any of these.
-Mike Elek

scott
Frequent Poster
Frequent Poster
Posts: 570
Joined: Thu Jul 10, 2014 11:06 am
x 2
x 76
Contact:

Re: Zenzanon-PS stiff aperture ring - fixable?

Post by scott » Mon Jun 07, 2021 1:32 pm

Thanks Mike. The detent clicks are still working, so I don't think it's that. I'm guessing old/congealed lube rather than anything physically damaged, but without opening it, dunno. Considering these have the integral shutter, I'm leaning towards letting it be for now. Just need to use it more. A whole lot more.

Julio1fer
Prolific Poster
Prolific Poster
Posts: 1110
Joined: Tue Mar 25, 2014 9:31 pm
x 3
x 30
Contact:

Re: Zenzanon-PS stiff aperture ring - fixable?

Post by Julio1fer » Mon Jun 07, 2021 8:51 pm

Surely you already tried the old combo of heat and a bit of torque?

scott
Frequent Poster
Frequent Poster
Posts: 570
Joined: Thu Jul 10, 2014 11:06 am
x 2
x 76
Contact:

Re: Zenzanon-PS stiff aperture ring - fixable?

Post by scott » Tue Jun 08, 2021 11:26 am

Julio1fer wrote:
Mon Jun 07, 2021 8:51 pm
Surely you already tried the old combo of heat and a bit of torque?
Actually I have not. Always had it in my head heat + lens = bad. How would you do this, hair dryer along the aperture ring?

Julio1fer
Prolific Poster
Prolific Poster
Posts: 1110
Joined: Tue Mar 25, 2014 9:31 pm
x 3
x 30
Contact:

Re: Zenzanon-PS stiff aperture ring - fixable?

Post by Julio1fer » Wed Jun 09, 2021 11:12 pm

Whatever gets the lens area you want to unstuck to about 110 F should do. Maybe more. You need to give enough time for the old grease to melt down. A hair dryer might work, also leaving the lens in the car on the sun. Heating should be slow. No problem in heating the whole lens at those temperatures, the lens can work in the tropics or desert environment.

As soon as the lens gets really warm, try to move the ring energically.

Probably PF or other experienced people can chime in.

scott
Frequent Poster
Frequent Poster
Posts: 570
Joined: Thu Jul 10, 2014 11:06 am
x 2
x 76
Contact:

Re: Zenzanon-PS stiff aperture ring - fixable?

Post by scott » Fri Jun 11, 2021 11:19 am

Worth a shot. Of course, after most of a week in the 90s, high today of 69. Going to be a bit before it's warm enough again to heat the truck interior up enough to try this...

PFMcFarland
Super Member
Super Member
Posts: 2165
Joined: Tue Apr 29, 2014 11:02 pm
x 260
x 45
Contact:

Re: Zenzanon-PS stiff aperture ring - fixable?

Post by PFMcFarland » Fri Jun 11, 2021 9:02 pm

I'll agree that the problem is most likely old lubricant. I don't know if that is what happened to my 28mm Leica R lens, but the aperture ring broke, and it cost over $300 to get it fixed. Luckily the lens is worth twice that so it was easy to make the call and get it fixed.

The problem with heating the lens to loosen the old lube is you also will make the helical lube runny, and once that stuff starts flowing it usually settles on the aperture and shutter blades, then you really have a situation. Best to get the lens serviced where they will not only restore the functionality, but also apply new lubricant for many more years of use.

PF
Waiting for the light

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests