Page 3 of 4

Re: Oops...

Posted: Thu Mar 25, 2021 12:38 pm
by scott
titrisol wrote:
Thu Mar 18, 2021 4:24 pm
PFMcFarland recommended PB Blaster... after 3 days in the stuff it moved!
I'm a believer!

It smells like a combination of aliphatic and aromatic low weight hydrocarbons and it dissolved the agfa green goo.
A paper towel full and 3 qtips of green
Okay, 10 minutes in front of a hair dryer on high did nothing but burn my finger. Explain the PB Blaster process please - are you submerging the glued together cells in the stuff or just dripping onto the joint between them?

Re: Oops...

Posted: Thu Mar 25, 2021 3:01 pm
by titrisol
I put the cells in a35mm film canister and almost covered them in PB Blaster; put the cap on and walked away.
I left them there for a couple of days and when I tried again with a lens wrench the front element moved; there was resistance initially but it came out.

Most of the green agfa epoxy was soft; and came out relatively easy.
I then cleaned the whole thing with IPA and greased the threads

The next stuck cells went into the same pb blaster and after 3 days, same thing
SO I got 3 unstuck cells with the same penetrant.

Re: Oops...

Posted: Mon Apr 05, 2021 7:38 pm
by PFMcFarland
Okay, I don't recall suggesting PB Blaster, or even using the stuff, but if it works for you, go for it. I usually soaked mine in 90% alcohol for days, sometimes with a little heat applied afterward.

PF

Re: Oops...

Posted: Tue Apr 06, 2021 12:30 am
by alexvaras
PFMcFarland wrote:
Mon Apr 05, 2021 7:38 pm
Okay, I don't recall suggesting PB Blaster, or even using the stuff, but if it works for you, go for it. I usually soaked mine in 90% alcohol for days, sometimes with a little heat applied afterward.

PF
The effect of “PFMcFarland suggested this” will automatically make the user a believer and will try it with success (apparently)
I would Copyright myself if I were you ;)

Re: Oops...

Posted: Wed Apr 07, 2021 11:59 am
by scott
Interesting, and i'm reading this about 20 minutes late. Bought some of the B'laster penetrant and the cells are soaking now. A little worried that the lens coatings will be fried by this stuff, but in for a penny...

I'll pull them out Saturday and see if they move. Stay tuned...

Re: Oops...

Posted: Wed Apr 07, 2021 12:24 pm
by titrisol
It is easy to clean any residue with IsoPropyl Alcohol, coating are OK I guess

Re: Oops...

Posted: Wed Apr 07, 2021 1:47 pm
by alexvaras
Same curiosity here... I remember I have a Compur shutter with one ring in the front thread that I can’t take it out... what effect could this PB thingy have in the aperture blades? Is this PB Blaster any kind of dissolvent or just penetrating oil?

Re: Oops...

Posted: Wed Apr 07, 2021 2:47 pm
by titrisol
Is a very good penetrating oil, with many aliphatic and aromatic hydrocarbons,
https://blasterproducts.com/product/pb- ... penetrant/
MSDS https://blasterproducts.com/wp-content/ ... 9-24_1.pdf

I guess that a few drops will help you loosen the ring in the Compur, but the electric contact cleanr might work as well on this one

Re: Oops...

Posted: Wed Apr 07, 2021 3:04 pm
by scott
My usual solvent, Goof-off, is a mix of solvents (acetone, xylene, etc.). Totally clear, dries with no residue. This stuff is in a spray, but sprays as a liquid stream. It feels a bit oily, and is distinctly yellow in color.

Re: Oops...

Posted: Thu Apr 08, 2021 11:40 am
by Bennybee
On my Solinette I used WD40 with success. I guess it all depends how hardened the old stuff is, or how long since the parts moved.